Not rated
CVE-2024-45478 Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0
Description
Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Ranger 2.4 | 2.4.0 → < 2.5.0 | 2.5.0 |
References
- cwiki.apache.org cwiki.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Ranger
The 23 CVEs of Apache Ranger →
CVE-2026-28672
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Ranger
Not rated
CVE-2026-32227
SQL Injection vulnerability vulnerability in Apache Ranger
Not rated
CVE-2026-40920
Privilege Escalation via URL Parameter is reported in Apache Ranger versions <= 2.8.0
Not rated
CVE-2026-42537
Remote Code Execution via JDBC URL Injection in Apache…
Not rated