Skip to content
Not rated

CVE-2024-45033 Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider

Description

Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. This issue affects Apache Airflow Fab Provider: before 1.5.2. When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0 Users are recommended to upgrade to version 1.5.2, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Airflow Fab Provider 1.5 earliest → < 1.5.2 1.5.2

References

Timeline

  1. Published
  2. Last modified
The 9 CVEs of Apache Airflow Fab Provider →
Track this CVE