6.8
Medium
CVE-2024-4420 There exists a Denial of service vulnerability in Tink-cc in versions prior to 2.1.3. * An adversary can crash…
Description
There exists a Denial of service vulnerability in Tink-cc in versions prior to 2.1.3. * An adversary can crash binaries using the crypto::tink::JsonKeysetReader in tink-cc by providing an input that is not an encoded JSON object, but still a valid encoded JSON element, for example a number or an array. This will crash as Tink just assumes any valid JSON input will contain an object. * An adversary can crash binaries using the crypto::tink::JsonKeysetReader in tink-cc by providing an input containing many nested JSON objects. This may result in a stack overflow. We recommend upgrading to version 2.1.3 or above
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Tink 2.0 | 2.0.0 → < 2.1.3 | 2.1.3 |
| Tink (Legacy) 1.7 | earliest → 1.7.0 | No fix stated |