Not rated
CVE-2024-41151 Deserialization of Untrusted Data vulnerability in Apache HertzBeat
Description
Deserialization of Untrusted Data vulnerability in Apache HertzBeat. This vulnerability can only be exploited by authorized attackers. This issue affects Apache HertzBeat: before 1.6.1. Users are recommended to upgrade to version 1.6.1, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache HertzBeat 1.6 | earliest → < 1.6.1 | 1.6.1 |
| HertzBeat 1.6 | earliest → < 1.6.1 | 1.6.1 |
References
- lists.apache.org lists.apache.org
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache HertzBeat
The 7 CVEs of Apache HertzBeat →
CVE-2026-114442
Apache HertzBeat versions 1.7.1, 1.7.2, 1.7.3, 1.8.0, and 1.9.0 have incomplete XPath expression validation in the…
Not rated
CVE-2026-24343
Improper Neutralization of Data within XPath Expressions ('XPath Injection') vulnerability in Apache HertzBeat
Not rated
CVE-2024-56736
Server-Side Request Forgery (SSRF) vulnerability in Apache HertzBeat
Not rated
CVE-2024-45791
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache HertzBeat
Not rated