9.4
Critical
CVE-2024-32838 SQL Injection vulnerability in various API endpoints - offices, dashboards, etc
Description
SQL Injection vulnerability in various API endpoints - offices, dashboards, etc. Apache Fineract versions 1.9 and before have a vulnerability that allows an authenticated attacker to inject malicious data into some of the REST API endpoints' query parameter. Users are recommended to upgrade to version 1.10.1, which fixes this issue. A SQL Validator has been implemented which allows us to configure a series of tests and checks against our SQL queries that will allow us to validate and protect against nearly all potential SQL injection attacks.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Fineract 1.4 | 1.4 → 1.9 | No fix stated |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Fineract
The 22 CVEs of Apache Fineract →
CVE-2026-64618
Improper Neutralization of Special Elements used in an SQL Command ("SQL Injection") vulnerability exists in Apache…
Not rated
CVE-2026-65874
This issue affects Apache Fineract versions up to and including 1.15.0
Not rated
CVE-2026-57821
A SQL Injection vulnerability exists in Apache Fineract's Office Search API (GET /api/v1/offices) in versions up to…
Not rated
CVE-2026-35152
A SQL Injection vulnerability exists in Apache Fineract's Report Execution API (runreports endpoint) in versions up to…
Not rated