Not rated
CVE-2024-31868 Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can modify helium.json and exposure XSS attacks to normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Zeppelin 0.8 | 0.8.2 → < 0.11.1 | 0.11.1 |
References
- github.com github.com
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Zeppelin
The 25 CVEs of Apache Zeppelin →
CVE-2026-44615
Path traversal vulnerability in Apache Zeppelin
Not rated
CVE-2026-44617
LDAP filter injection vulnerability in Apache Zeppelin
Not rated
CVE-2026-44616
LDAP injection vulnerability in Apache Zeppelin
Not rated
CVE-2026-44613
Cross-Site Request Forgery (CSRF) vulnerability in Apache Zeppelin
Not rated