Skip to content
6.4 Medium

CVE-2024-2660 Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more…

Description

Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.

Affected products and versions

Product Affected versions Fixed in
Vault 1.14 1.14.0 → < 1.16.0 1.16.0
Vault Enterprise 1.14 1.14.0 → < 1.16.0 1.16.0
The 43 CVEs of Vault →
Track this CVE