Not rated
CVE-2024-23807 The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the…
Description
The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs. Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable. This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Xerces C++ 3.0 | 3.0.0 → < 3.2.5 | 3.2.5 |
| xerces-c 3.0 | 3.0.0 → < 3.2.5 | 3.2.5 |
References
- github.com github.com
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified