Not rated
CVE-2024-22399 Deserialization of Untrusted Data vulnerability in Apache Seata. When developers disable authentication on the…
Description
Deserialization of Untrusted Data vulnerability in Apache Seata. When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol. This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0. Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Seata | 2.0.0 | No fix stated |
| Apache Seata 1.0 | 1.0.0 → 1.8.0 | No fix stated |
| seata | 2.0.0 | No fix stated |
| seata 1.0 | 1.0.0 → 1.8.0 | No fix stated |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified