Skip to content
7.3 High

CVE-2023-7158 A vulnerability was found in MicroPython up to 1.21.0

Description

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Affected products and versions

Product Affected versions Fixed in
MicroPython 1.21.0 No fix stated
MicroPython 1.20.0 No fix stated
MicroPython 1.19.0 No fix stated
MicroPython 1.18.0 No fix stated
MicroPython 1.17.0 No fix stated
MicroPython 1.16.0 No fix stated
MicroPython 1.15.0 No fix stated
MicroPython 1.14.0 No fix stated
MicroPython 1.13.0 No fix stated
The 6 CVEs of MicroPython →
Track this CVE