Not rated
CVE-2023-49920 Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET…
Description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Airflow 2.7 | 2.7.0 → < 2.8.0 | 2.8.0 |
References
- github.com github.com
- lists.apache.org lists.apache.org
- www.openwall.com www.openwall.com
Timeline
- Published
- Last modified
Other CVEs of Apache Airflow
The 153 CVEs of Apache Airflow →
CVE-2026-86473
Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie
Not rated
CVE-2026-75158
Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter…
Not rated
CVE-2026-82355
When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token,…
Not rated
CVE-2026-75157
Apache Airflow's asset queued-events DELETE endpoints checked the caller's Dag-axis permission with `READ` instead of…
Not rated