Not rated
CVE-2023-47265 Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded…
Description
Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users. Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Airflow 2.6 | 2.6.0 → < 2.8.0 | 2.8.0 |
References
- github.com github.com
- lists.apache.org lists.apache.org
- www.openwall.com www.openwall.com
Timeline
- Published
- Last modified
Other CVEs of Apache Airflow
The 153 CVEs of Apache Airflow →
CVE-2026-86473
Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie
Not rated
CVE-2026-75158
Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter…
Not rated
CVE-2026-82355
When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token,…
Not rated
CVE-2026-75157
Apache Airflow's asset queued-events DELETE endpoints checked the caller's Dag-axis permission with `READ` instead of…
Not rated