Skip to content
Not rated

CVE-2023-45757 Security vulnerability in Apache…

Description

Security vulnerability in Apache bRPC <=1.6.0 on all platforms allows attackers to inject XSS code to the builtin rpcz page. An attacker that can send http request to bRPC server with rpcz enabled can inject arbitrary XSS code to the builtin rpcz page. Solution (choose one of three): 1. upgrade to bRPC > 1.6.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.6.1/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch:  https://github.com/apache/brpc/pull/2411 3. disable rpcz feature

Affected products and versions

Product Affected versions Fixed in
Apache bRPC 0.9 0.9.0 → 1.6.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 41 CVEs of Apache bRPC →
Track this CVE