Skip to content
Not rated

CVE-2023-35005 In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations

Description

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

Affected products and versions

Product Affected versions Fixed in
Apache Airflow 2.5 2.5.0 → < 2.6.2 2.6.2

References

Timeline

  1. Published
  2. Last modified
The 153 CVEs of Apache Airflow →
Track this CVE