2.7
Low
CVE-2023-1296 HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.5.0 did not correctly enforce deny policies applied to a workload’s…
Description
HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.5.0 did not correctly enforce deny policies applied to a workload’s variables. Fixed in 1.4.6 and 1.5.1.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Nomad | 1.5.0 | No fix stated |
| Nomad 1.4 | 1.4.0 → < 1.4.6 | 1.4.6 |
| Nomad Enterprise | 1.5.0 | No fix stated |
| Nomad Enterprise 1.4 | 1.4.0 → < 1.4.6 | 1.4.6 |
Other CVEs of Nomad
The 24 CVEs of Nomad →
CVE-2026-119168
HashiCorp Nomad and Nomad Enterprise are vulnerable to symlink following during same-client allocation data migration…
8.8
High
CVE-2026-107347
HashiCorp Nomad and Nomad Enterprise are vulnerable to symlink following during dispatch payload and executor log writes…
8.4
High
CVE-2026-102260
HashiCorp Nomad and Nomad Enterprise are vulnerable to cross-namespace authorization bypasses in several read-only API…
4.3
Medium
CVE-2026-14896
HashiCorp Nomad and Nomad Enterprise are vulnerable to a cross-namespace authorization bypass in the dynamic host…
4.2
Medium