Skip to content
Not rated

CVE-2021-38153 Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks…

Description

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Affected products and versions

Product Affected versions Fixed in
Apache Kafka 2.8 earliest → 2.8.0 No fix stated
Apache Kafka 2.7 earliest → 2.7.1 No fix stated
Apache Kafka 2.6 earliest → 2.6.2 No fix stated
Apache Kafka 2.5 earliest → 2.5.1 No fix stated
Apache Kafka 2.4 earliest → 2.4.1 No fix stated
Apache Kafka 2.3 earliest → 2.3.1 No fix stated
Apache Kafka 2.2 earliest → 2.2.2 No fix stated
Apache Kafka 2.1 earliest → 2.1.1 No fix stated
Apache Kafka 2.0 earliest → 2.0.1 No fix stated
The 23 CVEs of Apache Kafka →
Track this CVE