Skip to content
Not rated

CVE-2020-25630 A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user…

Description

A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Affected products and versions

Product Affected versions Fixed in
Moodle Versions not published

References

Timeline

  1. Published
  2. Last modified
The 89 CVEs of Moodle →
Track this CVE