Not rated
CVE-2017-15708 In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI)
Description
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Synapse | 3.0.0 | No fix stated |
| Apache Synapse | 2.1.0 | No fix stated |
| Apache Synapse | 2.0.0 | No fix stated |
| Apache Synapse | 1.2 | No fix stated |
| Apache Synapse 1.1 | 1.1.1 → 1.1.2 | No fix stated |
References
- 102154 www.securityfocus.com
- [dev] 20171210 [CVE-2017-15708] Apache Synapse Remote Code Execution Vulnerability lists.apache.org
- www.oracle.com www.oracle.com
- www.oracle.com www.oracle.com
- [doris-commits] 20210402 [GitHub] [incubator-doris] zh0122 opened a new pull request #5595: [FE][Fix]Update commons-collections to fix a security issue lists.apache.org
- GLSA-202107-37 security.gentoo.org
Timeline
- Published
- Last modified