Skip to content
6.7 Medium

CVE-2026-88922 The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive…

Description

The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive decompression handling that may allow a crafted archive to cause extracted files to be created with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local actor to obtain the privileges of the extracting process. This vulnerability (CVE-2026-88922) is fixed in go-getter 1.8.9 and 2.2.4.

Affected products and versions

Product Affected versions Fixed in
Shared library 1.0 1.0.1 → < 2.2.4 2.2.4
The 10 CVEs of Shared library →
Track this CVE