Skip to content
Not rated

CVE-2026-62440 Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant…

Description

Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.22.1.1 or later, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache CloudStack 4.21 4.21.0.0 → 4.22.1.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 51 CVEs of Apache CloudStack →
Track this CVE