Skip to content
8.8 High

CVE-2026-54232 vLLM is an inference and serving engine for large language models (LLMs)

Description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

Affected products and versions

Product Affected versions Fixed in
vllm 0.22 earliest → < 0.22.1 0.22.1

References

Timeline

  1. Published
  2. Last modified
The 121 CVEs of vllm →
Track this CVE