Skip to content
2.3 Low

CVE-2026-49231 Authentication Bypass by Spoofing vulnerability in opa plugin

Description

Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.5 3.5.0 → 3.16.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE