Skip to content
6.3 Medium

CVE-2026-49230 Improper Validation of Integrity Check Value vulnerability in Apache APISIX

Description

Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.  This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.8 3.8.0 → 3.16.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE