Skip to content
Not rated

CVE-2026-49157 Incorrect Default Permissions vulnerability in Apache ActiveMQ

Description

Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache ActiveMQ 6.0 6.0.0 → < 6.2.6 6.2.6
Apache ActiveMQ 5.19 earliest → < 5.19.7 5.19.7

References

Timeline

  1. Published
  2. Last modified
The 40 CVEs of Apache ActiveMQ →
Track this CVE