Skip to content
Not rated

CVE-2026-45812 Incorrect Calculation of Buffer Size vulnerability in Apache NimBLE when processing Legacy Advertising Report HCI event

Description

Incorrect Calculation of Buffer Size vulnerability in Apache NimBLE when processing Legacy Advertising Report HCI event. When a single HCI advertising report event bundles multiple reports, NimBLE miscalculated the offset to the next report. This can cause the host to read past the end of the buffer and deliver a GAP event with bogus data to the application. Severity is low: NimBLE's own controller never batches multiple reports into one event, so this only matters when NimBLE's host is paired with a third-party controller that does. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache NimBLE 1.9 earliest → 1.9.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 11 CVEs of Apache NimBLE →
Track this CVE