9.3
Critical
Exploited
CVE-2026-42208 BerriAI LiteLLM SQL Injection Vulnerability
Active exploitation observed
· CISA KEV catalogue
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware campaigns
Not observed so far
Weakness
CWE-89
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| litellm 1.81 | 1.81.16 → < 1.83.7 | 1.83.7 |
| Lightspeed Core | Versions not published | |
| Red Hat Ansible Automation Platform 2 | Versions not published | |
| Red Hat OpenShift AI (RHOAI) | Versions not published |
References
- github.com github.com
- github.com github.com
Timeline
- Published
- Added to the KEV catalogue
- Last modified
Other CVEs of litellm
The 40 CVEs of litellm →
CVE-2026-114612
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format
9.9
Critical
CVE-2026-108575
A vulnerability has been found in BerriAI LiteLLM up to 1.94.0
5.3
Medium
CVE-2026-108574
A flaw has been found in BerriAI LiteLLM up to 1.95.0
5.3
Medium
CVE-2026-93355
LiteLLM contains a weak authentication vulnerability that allows an attacker holding a valid JWT from the configured…
7.6
High