Skip to content
Not rated

CVE-2026-41869 Missing Authorization, Improper Resource Shutdown and Job Interruption vulnerability in Apache Nutch Server (Nutch REST…

Description

Missing Authorization, Improper Resource Shutdown and Job Interruption vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Affected products and versions

Product Affected versions Fixed in
Apache Nutch 1.10 1.10 → 1.22 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 4 CVEs of Apache Nutch →
Track this CVE