Skip to content
7.0 High

CVE-2026-39999 Authentication Bypass by Spoofing vulnerability in Apache APISIX

Description

Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 2.2 2.2 → 3.16.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE