Skip to content
8.8 High

CVE-2026-18733 A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors…

Description

A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors to execute arbitrary operating system commands on the agent's host via a crafted prompt that sets the non_interactive parameter to true, bypassing the human consent gate. To remediate this issue, users should upgrade to version 0.8.0.

Affected products and versions

Product Affected versions Fixed in
strands-agents-tools 0.8 earliest → < 0.8.0 0.8.0
The 2 CVEs of strands-agents-tools →
Track this CVE