Skip to content
Not rated

CVE-2026-104713 Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin

Description

Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Struts 7.0 7.0.0 → 7.3.0 No fix stated
Apache Struts 6.0 6.0.0 → 6.11.0 No fix stated
Apache Struts 2.5 2.5.0 → 2.5.33 No fix stated
Apache Struts 2.1 2.1.8 → 2.3.37 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 33 CVEs of Apache Struts →
Track this CVE