Skip to content
Not rated

CVE-2025-64775 Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Struts 7.0 7.0.0 → 7.0.3 No fix stated
Apache Struts 2.0 2.0.0 → 6.7.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 33 CVEs of Apache Struts →
Track this CVE