Skip to content
5.3 Medium

CVE-2024-7711 An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server, allowing an attacker to update…

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server, allowing an attacker to update the title, assignees, and labels of any issue inside a public repository. This was only exploitable inside a public repository. This vulnerability affected GitHub Enterprise Server versions before 3.14 and was fixed in versions 3.13.3, 3.12.8, and 3.11.14. Versions 3.10 of GitHub Enterprise Server are not affected. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products and versions

Product Affected versions Fixed in
GitHub Enterprise Server 3.13 3.13.0 → 3.13.2 No fix stated
GitHub Enterprise Server 3.12 3.12.0 → 3.12.7 No fix stated
GitHub Enterprise Server 3.11 3.11.0 → 3.11.13 No fix stated
The 46 CVEs of GitHub Enterprise Server →
Track this CVE