6.9
Medium
CVE-2024-7055 A vulnerability was found in FFmpeg up to 7.0.1
Description
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| ffmpeg 7.0 | 7.0.0 → 7.0.1 | No fix stated |
References
- VDB-273651 | FFmpeg pnmdec.c pnm_decode_frame heap-based overflow vuldb.com
- VDB-273651 | CTI Indicators (IOB, IOC, IOA) vuldb.com
- Submit #376532 | GitHub FFmpeg 6.1.1 Buffer Overflow vuldb.com
- github.com github.com
- ffmpeg.org ffmpeg.org
- ffmpeg.org ffmpeg.org
Timeline
- Published
- Last modified
Other CVEs of ffmpeg
The 11 CVEs of ffmpeg →
CVE-2026-90816
A vulnerability was found in FFmpeg 8.0.x
5.3
Medium
CVE-2026-90815
A vulnerability has been found in FFmpeg up to 4.4.6/5.1.8/6.1.4/7.1.3/8.0.1
5.3
Medium
CVE-2025-1816
A vulnerability classified as problematic has been found in FFmpeg up to 6e26f57f672b05e7b8b052007a83aef99dc81ccb
5.3
Medium
CVE-2025-1594
A vulnerability, which was classified as critical, was found in FFmpeg up to 7.1
5.3
Medium