Skip to content
Not rated

CVE-2024-32638 Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using…

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.8 3.8.0 → 3.9.0 No fix stated
Apache_APISIX 3.8.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE