Skip to content
4.3 Medium

CVE-2024-24772 A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak…

Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Superset 3.1 3.1.0 → < 3.1.1 3.1.1
Apache Superset 3.0 earliest → < 3.0.4 3.0.4

References

Timeline

  1. Published
  2. Last modified
The 65 CVEs of Apache Superset →
Track this CVE