Skip to content
Not rated

CVE-2023-49920 Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET…

Description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

Affected products and versions

Product Affected versions Fixed in
Apache Airflow 2.7 2.7.0 → < 2.8.0 2.8.0

References

Timeline

  1. Published
  2. Last modified
The 153 CVEs of Apache Airflow →
Track this CVE