Skip to content
Not rated

CVE-2023-41916 In Apache Linkis =1.4.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql…

Description

In Apache Linkis =1.4.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will trigger arbitrary file reading. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis = 1.4.0 will be affected.  We recommend users upgrade the version of Linkis to version 1.5.0.

Affected products and versions

Product Affected versions Fixed in
Apache Linkis DataSource 1.4 1.4.0 → < 1.5.0 1.5.0

References

Timeline

  1. Published
  2. Last modified
The 4 CVEs of Apache Linkis DataSource →
Track this CVE