Not rated
Exploited
CVE-2023-33246 Apache RocketMQ Command Execution Vulnerability
Active exploitation observed
· CISA KEV catalogue
Required action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware campaigns
Not observed so far
Weakness
CWE-94
Description
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache RocketMQ 5.1 | earliest → 5.1.0 | No fix stated |
References
- lists.apache.org lists.apache.org
- packetstormsecurity.com packetstormsecurity.com
- www.openwall.com www.openwall.com
Timeline
- Published
- Added to the KEV catalogue
- Last modified