8.4
High
CVE-2022-45048 Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution…
Description
Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability. This issue affects Apache Ranger: 2.3.0. Users are recommended to update to version 2.4.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Ranger | 2.3.0 | No fix stated |
| ranger | 2.3.0 | No fix stated |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Ranger
The 23 CVEs of Apache Ranger →
CVE-2026-28672
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Ranger
Not rated
CVE-2026-32227
SQL Injection vulnerability vulnerability in Apache Ranger
Not rated
CVE-2026-40920
Privilege Escalation via URL Parameter is reported in Apache Ranger versions <= 2.8.0
Not rated
CVE-2026-42537
Remote Code Execution via JDBC URL Injection in Apache…
Not rated