Skip to content
6.4 Medium

CVE-2020-8904 An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0

Description

An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0. As the ecall_restore function fails to validate the range of the output_len pointer, an attacker can manipulate the tmp_output_len value and write to an arbitrary location in the trusted (enclave) memory. We recommend updating Asylo to version 0.6.0 or later.

Affected products and versions

Product Affected versions Fixed in
Asylo 0.6 earliest → < 0.6.0 0.6.0
The 16 CVEs of Asylo →
Track this CVE