Vulnerabilities of n/a https://github.com/rails/rails
Is your version affected?
CVE list
| CVE | Summary | Score | Published |
|---|---|---|---|
| CVE-2023-22792 | A regular expression based DoS vulnerability in Action Dispatch <6.0.6.1,< 6.1.7.1, and <7.0.4.1 | 7.5 High | Feb 9, 2023 |
| CVE-2023-22797 | An open redirect vulnerability is fixed in Rails 7.0.4.1 with the new protection against open redirects from calling… | 6.1 Medium | Feb 9, 2023 |
| CVE-2023-22796 | A regular expression based DoS vulnerability in Active Support <6.1.7.1 and <7.0.4.1 | Not rated | Feb 9, 2023 |
| CVE-2023-22795 | A regular expression based DoS vulnerability in Action… | Not rated | Feb 9, 2023 |
| CVE-2023-22794 | A vulnerability in ActiveRecord <6.0.6.1, v6.1.7.1 and v7.0.4.1 related to the sanitization of comments | Not rated | Feb 9, 2023 |
| CVE-2022-44566 | A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1 | 7.5 High | Feb 9, 2023 |
| CVE-2022-32224 | A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record <… | 9.8 Critical | Dec 5, 2022 |
| CVE-2022-27777 | A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if… | Not rated | May 26, 2022 |
| CVE-2022-22577 | An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like… | Not rated | May 26, 2022 |
| CVE-2022-21831 | A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via… | Not rated | May 26, 2022 |
| CVE-2021-44528 | A open redirect vulnerability exists in Action Pack >= 6.0.0 that could allow an attacker to craft a… | Not rated | Jan 7, 2022 |
| CVE-2021-22942 | A possible open redirect vulnerability in the Host Authorization middleware in Action Pack >= 6.0.0 that could allow… | Not rated | Oct 18, 2021 |
| CVE-2021-22904 | The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service… | Not rated | Jun 11, 2021 |
| CVE-2021-22903 | The actionpack ruby gem before 6.1.3.2 suffers from a possible open redirect vulnerability | Not rated | Jun 11, 2021 |
| CVE-2021-22902 | The actionpack ruby gem (a framework for handling and responding to web requests in Rails) before 6.0.3.7, 6.1.3.2… | Not rated | Jun 11, 2021 |
| CVE-2021-22885 | A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the… | Not rated | May 27, 2021 |
| CVE-2021-22881 | The Host Authorization middleware in Action Pack before 6.1.2.1, 6.0.3.5 suffers from an open redirect vulnerability | Not rated | Feb 11, 2021 |
| CVE-2021-22880 | The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of… | Not rated | Feb 11, 2021 |
| CVE-2020-8264 | In actionpack gem >= 6.0.0, a possible XSS vulnerability exists when an application is running in development mode… | Not rated | Jan 6, 2021 |
| CVE-2020-8166 | A CSRF forgery vulnerability exists in rails < 5.2.5, rails < 6.0.4 that makes it possible for an attacker to, given a… | 4.3 Medium | Jul 2, 2020 |
| CVE-2020-8163 | The is a code injection vulnerability in versions of Rails prior to 5.0.1 that wouldallow an attacker who controlled the… | Not rated | Jul 2, 2020 |
| CVE-2020-8185 | A denial of service vulnerability exists in… | Not rated | Jul 2, 2020 |
| CVE-2020-8165 | A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an… | Not rated | Jun 19, 2020 |
| CVE-2020-8164 | A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker… | Not rated | Jun 19, 2020 |
| CVE-2020-8162 | A client side enforcement of server side security vulnerability exists in rails < 5.2.4.2 and rails < 6.0.3.1… | Not rated | Jun 19, 2020 |
Other n/a products
n/a 144660
Android 2441
kernel 279
Open5GS 125
Intel(R) Processors 119
BIG-IP 110
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions 106
HPE Intelligent Management Center (IMC) PLAT 105
Moodle 89
Aruba ClearPass Policy Manager 83
GPAC 80
postgresql 79