Not rated
CVE-2026-83525 Apache Kafka: Incorrect boolean operator in FetchSnapshot RPC handler allows authenticated network clients to crash the KRaft controller via a malformed request.
Description
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Kafka 4.3 | 4.3.0 → < 4.3.2 | 4.3.2 |
| Apache Kafka 2.8 | 2.8.0 → < 4.2.2 | 4.2.2 |
References
- github.com github.com
- kafka.apache.org kafka.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Kafka
The 23 CVEs of Apache Kafka →
CVE-2026-114349
Apache Kafka: Denial of service via unbounded memory allocation when decoding compressed record batches
Not rated
CVE-2026-112375
Apache Kafka: Unauthorized principal can read arbitrary broker files via IncrementalAlterConfigs
Not rated
CVE-2026-116593
Apache Kafka: Kafka Connect configuration provider values exposed via validation REST API endpoint
Not rated
CVE-2026-115644
Apache Kafka: Connect Admin REST API Authentication Bypass via Unapplied REST Extensions
Not rated