Skip to content
6.9 Medium

CVE-2026-6985 A weakness has been identified in Cesanta Mongoose up to 7.20

Description

A weakness has been identified in Cesanta Mongoose up to 7.20. This vulnerability affects the function handle_opt of the file /src/net_builtin.c of the component TCP Option Handler. This manipulation of the argument optlen causes infinite loop. The attack is possible to be carried out remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 7.21 is able to resolve this issue. Upgrading the affected component is advised. VulDB has contacted the vendor early and they confirmed quickly, that this issue got fixed already.

Affected products and versions

Product Affected versions Fixed in
Mongoose 7.21 earliest → < 7.21 7.21
Mongoose 7.20 No fix stated
Mongoose 7.19 No fix stated
Mongoose 7.18 No fix stated
Mongoose 7.17 No fix stated
Mongoose 7.16 No fix stated
Mongoose 7.15 No fix stated
Mongoose 7.14 No fix stated
Mongoose 7.13 No fix stated
Show the 13 other branches
Product Affected versions Fixed in
Mongoose 7.12 No fix stated
Mongoose 7.11 No fix stated
Mongoose 7.10 No fix stated
Mongoose 7.9 No fix stated
Mongoose 7.8 No fix stated
Mongoose 7.7 No fix stated
Mongoose 7.6 No fix stated
Mongoose 7.5 No fix stated
Mongoose 7.4 No fix stated
Mongoose 7.3 No fix stated
Mongoose 7.2 No fix stated
Mongoose 7.1 No fix stated
Mongoose 7.0 No fix stated
The 38 CVEs of Mongoose →
Track this CVE