Skip to content
Not rated

CVE-2026-66422 Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as…

Description

Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M1 → 11.0.24 No fix stated
Apache Tomcat 10.1 10.1.0-M1 → 10.1.57 No fix stated
Apache Tomcat 9.0 9.0.25 → 9.0.120 No fix stated
Apache Tomcat 8.5 8.5.46 → 8.5.100 No fix stated
Apache Tomcat 7.0 7.0.97 → 7.0.109 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE