Skip to content
Not rated

CVE-2026-63071 Improper Isolation or Compartmentalization vulnerability in Apache Syncope

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by tightening the Groovy security sandbox.

Affected products and versions

Product Affected versions Fixed in
Apache Syncope 4.1 4.1.0-M0 → 4.1.1 No fix stated
Apache Syncope 4.0 4.0.0-M0 → 4.0.6 No fix stated
Apache Syncope 3.0 3.0.0-M0 → 3.0.16 No fix stated
The 45 CVEs of Apache Syncope →
Track this CVE