8.8
High
Exploited
CVE-2026-59822 BerriAI LiteLLM Improper Authentication Vulnerability
Active exploitation observed
· CISA KEV catalogue
Required action
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
Ransomware campaigns
Not observed so far
Weakness
CWE-306, CWE-287
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| litellm 1.84 | earliest → < 1.84.0 | 1.84.0 |
References
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
Timeline
- Published
- Added to the KEV catalogue
- Last modified
Other CVEs of litellm
The 40 CVEs of litellm →
CVE-2026-114612
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format
9.9
Critical
CVE-2026-108575
A vulnerability has been found in BerriAI LiteLLM up to 1.94.0
5.3
Medium
CVE-2026-108574
A flaw has been found in BerriAI LiteLLM up to 1.95.0
5.3
Medium
CVE-2026-93355
LiteLLM contains a weak authentication vulnerability that allows an attacker holding a valid JWT from the configured…
7.6
High