Skip to content
5.9 Medium

CVE-2026-58185 The Apache Traffic Server intercept plugin has a use-after-free

Description

The Apache Traffic Server intercept plugin has a use-after-free. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Traffic Server 10.0 10.0.0 → 10.1.3 No fix stated
Apache Traffic Server 9.0 9.0.0 → 9.2.14 No fix stated
Apache Traffic Server 8.0 8.0.0 → 8.1.11 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 111 CVEs of Apache Traffic Server →
Track this CVE