7.1
High
CVE-2026-55514 vLLM is a library for LLM inference and serving
Description
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| vllm 0.12 | 0.12.0 → < 0.24.0 | 0.24.0 |
References
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
Timeline
- Published
- Last modified
Other CVEs of vllm
The 121 CVEs of vllm →
CVE-2026-115918
vLLM is an inference and serving engine for large language models
6.5
Medium
CVE-2026-115917
vLLM is an inference and serving engine for large language models
3.4
Low
CVE-2026-115916
vLLM is an inference and serving engine for large language models
6.5
Medium
CVE-2026-115915
vLLM is an inference and serving engine for large language models
8.1
High