Skip to content
Not rated

CVE-2026-50633 A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code…

Description

A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

Affected products and versions

Product Affected versions Fixed in
Apache CXF 4.2 4.2.0 → < 4.2.2 4.2.2
Apache CXF 4.0 4.0.0 → < 4.1.7 4.1.7
Apache CXF 3.6 earliest → < 3.6.12 3.6.12
Red Hat build of Apache Camel for Spring Boot 4 Versions not published
Red Hat Fuse 7 Versions not published
Red Hat JBoss Enterprise Application Platform Expansion Pack Versions not published
Red Hat build of Apache Camel 4.18.1.P1 for Spring Boot 3.5.16 Versions not published
The 56 CVEs of Apache CXF →
Track this CVE