Skip to content
8.2 High

CVE-2026-48145 Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift C++ bindings

Description

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Thrift 0.24 earliest → < 0.24.0 0.24.0

References

Timeline

  1. Published
  2. Last modified
The 91 CVEs of Apache Thrift →
Track this CVE